OSPF LAB 5-expert level

—————————————-
OSPF LAB 5
—————————————-
NOTES: 
Network slash and subnet:
/32 255.255.255.255 has only 1 IP address for like loopback IP, for device.
/31 255.255.255.254 has 2 IP address for point to point to link. 1 device within LAN to WAN.
/30   or 255.255.255.252 can have 4 IP, this is for connecting 2 devices together, like a router to router within LAN.
/29   or 255.255.255.248 can have 8 IP, 4 devices and 3 extra IP
/28 or 255.255.255.240 can have 16 IP, 8 devices and 5 extra IP
/27 or 255.255.255.224 can have 32 IP, 16 devices and 13 extra IP
/26 or 255.255.255.192 can have 64 IP, 32 devices and 29 extra IP
/25 or 255.255.255.128 can have 128 IP, 48 devices and 61 extra IP
/24    or 255.255.255.0 can have 190 IP, 96 devices and 93 extra IP
/23 or 255.255.254.0 can have 254 IP, 128 devices and 125 extra IP
————————–
Please see below topology:
192.168.1.0/30

255.255.255.252

Clue example:
a Transit Network: Router link to another router.
-Designated Router address: 192.168.4.1 is the next router that this router is connecting to.
-Router Interface address: 192.168.4.2 is the interface of this router ip address assigned.

-a Stub Network: is connecting into a switch or another off network router, the interface status is unknown.
-Link State ID: 0.0.0.x is the router ID
————————–
*The challenge is can you use only command to build out the network below.
Just imagine when you go into a company and that company has NO network diagram topology for you to look at.
How would you build a network diagram base on this 3 commands below?
sh ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.x

————————–

========================================
R1: 
========================================
conf t
int f2/0
ip add 192.168.1.2 255.255.255.252
shut
no shut
exit
int f3/1
ip add 192.168.7.2 255.255.255.0
shut
no shut
exit
router ospf 1
router-id 0.0.0.1
network 192.168.1.0 0.0.0.255 area 0
network 192.168.7.0 0.0.0.255 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.1
wr
!Link connected to: a Stub Network
! when a link of .7 is link to a Switch a non-router link
! or a Router link is DOWN
========================================
R2: 
========================================
conf t
int f3/0
ip add 192.168.1.1 255.255.255.252
shut
no shut
exit
int f2/0
ip add 192.168.3.1 255.255.255.248
shut
no shut
exit
router ospf 1
router-id 0.0.0.2
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.7 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.2
wr
!Link connected to: a Transit Network
! when a link of .3 is link to a Router link
========================================
R5: 
========================================
conf t
int f3/0
ip add 192.168.4.1 255.255.255.252
shut
no shut
exit
int f2/0
ip add 192.168.3.3 255.255.255.248
shut
no shut
exit
router ospf 1
router-id 0.0.0.5
network 192.168.4.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.7 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.5
wr
!Link connected to: a Transit Network
! when a link of .4 is link to a Router link
========================================
R6: 
========================================
conf t
int f3/1
ip add 192.168.4.2 255.255.255.252
shut
no shut
exit
int f3/0
ip add 10.10.10.1 255.255.255.252
shut
no shut
exit
router ospf 1
router-id 0.0.0.6
network 192.168.4.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.255 area 0
redis
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.6
wr
!Link connected to: a Transit Network
! when a link of 10 is link to a Router link
========================================
R3: 
========================================
conf t
int f3/0
ip add 192.168.2.1 255.255.255.252
shut
no shut
exit
int f3/1
ip add 192.168.5.1 255.255.255.252
shut
no shut
exit
int f2/0
ip add 192.168.3.2 255.255.255.248
shut
no shut
exit
router ospf 1
router-id 0.0.0.3
network 192.168.2.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.7 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.3
wr
!Link connected to: a Transit Network
! when a link of .3 is link to a Router link
========================================
R4: 
========================================
conf t
int f2/0
ip add 192.168.2.2 255.255.255.252
shut
no shut
exit
int f3/0
ip add 192.168.6.1 255.255.255.248
shut
no shut
exit
int f3/1
ip add 192.168.8.1 255.255.255.0
shut
no shut
exit
router ospf 1
router-id 0.0.0.4
network 192.168.2.0 0.0.0.255 area 0
network 192.168.6.0 0.0.0.255 area 0
network 192.168.8.0 0.0.0.255 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.4
wr
!Link connected to: a Transit Network
! when a link of .3 is link to a Router link
========================================
R7: 
========================================
conf t
int f3/0
ip add 192.168.5.2 255.255.255.252
shut
no shut
exit
int f2/0
ip add 192.168.6.2 255.255.255.248
shut
no shut
exit
router ospf 1
router-id 0.0.0.7
network 192.168.5.0 0.0.0.255 area 0
network 192.168.6.0 0.0.0.255 area 0
end
show ip int br
show ip pro
sh ip ospf data
sh ip ospf dat router 0.0.0.7
wr
!Link connected to: a Transit Network
! when a link of .3 is link to a Router link
========================================
—-END—–

Published by

Khmer Certified

Welcome to Khmer Certified. We're all about sharing the experienced in Information Technology. Our site is not an introduction to computer. We are more about sharing your journey that may take to get a job in an entry level IT - your first year in IT field

Leave a comment